CCleaner for Windows system requirements

CCleaner will run on any PC running Microsoft Windows 7 or above. If you're running one of the following operating systems, you're fine to run CCleaner:

  • Windows 10 (all editions, including 64-bit)
  • Windows 8 (all editions, including 64-bit)
  • Windows 7 (all editions, including 64-bit)
  • Windows Server 2008 to 2019 (all editions)

Since CCleaner is a small, quick program there are no minimum memory or hard drive requirements.

Note 1: For Windows XP or Vista, we recommend making use of the sunset version of CCleaner. You can find out more here: https://support.piriform.com/hc/en-us/articles/360040325231-Which-versions-of-CCleaner-work-with-Windows-XP-or-Vista-

Note 2: For Windows NT4, ME and 98, we recommend CCleaner Version 2.  For 2000 we recommend Version 3.

Note 3: CCleaner does not currently support Linux.