I am using v5.64 and my CCleaner app states that I cannot update any further. What does this mean?

This means that v5.64 is the last version of CCleaner you can use, while you stay on XP or Vista. If you try to update to a newer version of CCleaner, you will not be able to. However, v5.64 will receive any future critical security updates.

Like Microsoft, we recommend retiring your Windows XP/Vista computer and upgrading to a new one. This is especially true if your computer is connected to the internet, because XP and Vista are no longer receiving security updates and are vulnerable to online threats.

If you’re using XP or Vista and have a question, you can contact our support team on support@ccleaner.com