CCleaner for Mac system requirements

Currently, CCleaner for Mac requires an Apple Mac running OS X 10.8 to 10.14 Mojave.

* Please note that Macs with a PowerPC processor or 32-bit OS will NOT be able to run CCleaner *